Partial site unavailability

Incident Report for Vizcom

Resolved

The issue has been resolved. We are monitoring closely
Posted May 12, 2026 - 11:49 UTC

Investigating

We have identified an issue and are looking into a solution. Some parts of the app might be unstable and need reloading
Posted May 12, 2026 - 11:04 UTC
This incident affected: App.