Database performance degradation

Incident Report for Vizcom

Resolved

The issue has been resolved. We are monitoring closely
Posted May 12, 2026 - 18:20 UTC

Update

We've identified and resolved the issue. We are still monitoring closely
Posted May 12, 2026 - 16:49 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 12, 2026 - 16:30 UTC

Investigating

We are currently investigating database slowness affecting production services. Some users may experience delayed responses or intermittent errors while we work to identify the cause and restore normal performance.
Posted May 12, 2026 - 14:29 UTC
This incident affected: App.