Some users may be experiencing slow loading times

Incident Report for Vizcom

Resolved

The incident is resolved.
Posted May 11, 2026 - 19:59 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 11, 2026 - 18:34 UTC

Investigating

Vizcom is experiencing issues at the moment. We are investigating and will update you shortly.
Posted May 11, 2026 - 16:48 UTC
This incident affected: App.