Issues with image upload

Incident Report for Vizcom

Resolved

We identified that the issue was caused by a third party service maintenance window, and has been resolved
Posted Oct 24, 2025 - 00:00 UTC

Investigating

Some users may be experiencing issues with image upload via copy pasting in the app. We are investigating this issue.
Posted Oct 23, 2025 - 18:33 UTC
This incident affected: App.